Hayward Salt Cell

  • 79 Views
  • Last Post 3 weeks ago
Lori1976 posted this 09 April 2020

We recently opened our pool. We have T cell chlorine generator. It is 3 years old. It worked fine for a few days. Now My instant salt reading is extremely low which is causing the check salt indicator light to come on. Howevever, I've checked with a salt strip and it reads 3200. If I switch to off and then auto and then super chlorinate I can get the cell to recaliberate and the light will go off but after a few hours it reads check salt again. I then have to go through the whole process of "tricking" it to think I have enough salt in the pool. The water is currently 74 degrees so not too cold. Any ideas on what could be causing the low readings? 

Order By: Standard | Newest | Votes
InyoRob posted this 10 April 2020

Hello Lori - Assuming the salt cell is clean, my guess would be that the salt cell is beginning to fail. Recalibration is usually a way to trick the system but the real issue is still the information that the salt cell is sending back to the control. You could try adding some salt and bring the level up to 3500. This may cause the system to register at a normal level.

AZRustyNails posted this 11 April 2020

I have a similar situation with my Hayward cell. It is 2 years old. The controller says "Very Low Salt" but the test strip says 3600. Is there a way to test the cell? I don't think it should need to be replaced already.

jenkins0009 posted this 3 weeks ago

Hey just re-pinging this conversation. Maybe yalls figured it out?

I'm having a very similar issue with my T-15. I can trick the system and it starts generating for a few hours. But resetting it daily is a pain. I have manually tested my salt and it's consistently above 3000 ppm.

One additional step I took was to test my salt cell while it was removed from the system. I removed it from the piping, sealed off the 'exit end' of it and filled it with water, and turned the system on (lots of water - make sure you re-direct it all somewhere). After resetting the salt level again, the salt cell bubbled quite a bit - this means it is indeed making chlorine. Still trying to figure out why it needs to be reset so often....

-WJ

Close