NON STOP WATER FLOWING INTO PUMP!!!

  • 221 Views
  • Last Post 05 May 2018
Jonathan85 posted this 04 May 2018

So for some odd reason, ever since i opened our pool a few days ago, the pump is ALWAYS full with water. If i shut the power to the pump and i open the glass lid, water will flow out non stop. I can't for the life of me understand why. Today, i went to take apart the filter so i can clean off the grids and when i opened the drain, the water would still keep coming out non stop because the pipe that goes into the filter from the pump was pushing water through. I got the water to stop coming into the filter by turning the valve to backwash. That however does not stop the water filling up into the pump, and as i mentioned, anytime i start opening the lid to the pump, the water will flow out non stop! Any ideas as to why this is happening? Also, after cleaning out the filter grids, the pressure is reading roughly 17psi, i wonder if it's a bit higher because the pressue coming through from the pump with the water non stop shooting through.

Order By: Standard | Newest | Votes
InyoRob posted this 04 May 2018

Hello Jonathan - Do you have an above ground pool or an inground pool? Is the equipment pad located below the water level? 

Jonathan85 posted this 04 May 2018

It's a 20x40 inground pool. I would say the equipment is located maybe a few inches below the water level due to the grass sloping down a bit...

InyoRob posted this 04 May 2018

There should be a valve in front of your pump that you can turn so that water can't flow down to the pump while you have it open. Look for a ball valve or diverter valve that you can close. 

Jonathan85 posted this 05 May 2018

Thanks, Rob! I'll look for it today when i go back out there, but don't recall seeing one. Assuming there isn't, do you know if this would mean a defective pump/valve system? I did have a pool guy come install a new filter and valve port last season, so maybe something over there wont wrong? Just not sure if that's related to the pump...

InyoRob posted this 05 May 2018

There may be a defective check valve somewhere on the pressure side (after the pump) of the system. It wouldn't be an issue with the pump or filter.

Close