Pool pump humming then trips breaker. Is this type of corrosion normal from rain? Help please

  • 586 Views
  • Last Post 03 June 2020
Shellymarz posted this 22 May 2020

Hayward Super Pump corrosioni

Order By: Standard | Newest | Votes
Shellymarz posted this 22 May 2020

The pump has been off since November 2019

lwfri1 posted this 24 May 2020

Turn off power and disconnect power, remove motor from pump housing and try to see if you can turn impeller by hand. Might just be stuck from sitting idle of perhaps a seized bearing. If you know how and have a multimeter check motor windings for short to ground.

Shellymarz posted this 02 June 2020

Thank you. I did that and got it spin. I took it to pinch a penny to get new seals etc.  They were supposed to call me if it still didn't work. Instead they put a us motors 1.25 on it with my old impeller parts and called me and said it was ready. I said you were supposed to call before doing anything. He said he could take motor off but didn't have my old one to give back??? That motor was only 4 years old so that's why I was asking if the rust on it would cause it to break. He said the motor was all taken apart and ruined. All I did was follow directions to use wrench on impleller. He would just have to put capacitor and white piece back on. They were still attached!  I wanted some advice before I call the manager. Thanks so much 

lwfri1 posted this 03 June 2020

I don't know what to tell you. When someone rplaces a part they generally keep the old one to show the customer what was wrong with it. I can't tell from your picture if the motor was bad and the rust could only be surface damage or if the water got in the pump and caused damage. I would call the manager and explain what happened. You may need to pay for a new motor but they should at least discount it. Turning the motor to determine if it was seized should not damage it.

  • Liked by
  • Shellymarz
Close