Hayward Aqua Rite Error Code Guide

In my professional and personal experience, I have come to the conclusion that hardly anyone keeps owner’s manuals around. Don’t worry, this isn’t a dig at you but for some reason no one ever thinks he/she will need it again. Why? I am not certain. It is safe to say that somewhere down the line, the product will fail. And once it fails, the owner’s manual should be one of your first go-to documents for resources.

Sometimes, it’s not about the initial need for the manual, but for issues that spring up down the line. Pool owners are a group of consumers who I think need to keep all their manuals around, especially if you own any type of automation or salt chlorine system. The cool thing about salt systems is that when an error occurs, it typically gives you an error warning or code. That code gives customers a better idea of what the problem is and how to address the issue. But where are those codes and explanations usually? Take a wild guess.

The owner’s manual.

Hayward’s AquaRite Salt Chlorine Generator is one of the most popular lines on the market today. It is one of the easiest ways for you to sanitize your pool. Although I won’t get into too many details on how great the product is, you can read our customer reviews to get unfiltered opinions about it.

Still, one thing I do commend Hayward for is their simplistic error code guide. Compared to a lot of others on the market, going through their manual and troubleshooting guide was as customer friendly as you are going to get. But what good is a manual if customers don’t keep it?

Hayward Aqua Rite

Capture41The Hayward AquaRite system was strategic in the design in the sense that there aren’t too many variations of error codes programmed into their system. Unlike the Jandy AquaPure unit, which displays a number that then corresponds to a particular error, the Hayward Aqua Rite is simplistic in nature. It tells you the source of the issue.

If you take a look at the picture on the left, there are only 4 different error functions: No Flow, Check Salt, High Salt, and Inspect Cell. Although there may be several reasons for the error code to appear, having only 4 possibilities is great odds for a pool owner. It also makes it very clear to the pool owner what the issue might be once they venture out to the system. Let’s explore the different Hayward Aqua Rite error codes, what they mean, and how you can get rid of them.

 

click here to find your replacement Salt System Parts

 

Check Salt & Inspect Cell

Seeing as this is a salt chlorine generator, one of the most frequent error codes you will see will have to do with your salt checksaltlevels or the cell where the salt is produced. And because one directly affects the other, both lights will appear when there is an error concerning the salt levels.  Let’s dig a little deeper.

I. ‘Check Salt’ Light & ‘Inspect Cell’ Light Flash Together

When both these lights flash together, it means your salt level is between 2500 ppm and2600 ppm. At this moment chlorine is still being produced, however your salt levels are dwindling. Keep in mind, your ideal salt level should read 3200 ppm. Your AquaRite system may be working efficiently and your pool may be clear at the moment, but in a week or so, it may not be the case anymore.

Remedies:

  1. Independently verify the salt levels in your swimming pool. You can utilize one of our at home testing kits, or you can get your water tested at your local pool store.
  2. Once your water has been tested, add salt to your pool to bring your levels back to the recommended 3200 ppm. You can review how to add salt on our site, as well.
  3. Inspect and clean cell if, necessary.

 

II. ‘Check Salt’ Light & ‘Insect Cell’ Light Stays On

If both the Check Salt and the Inspect Cell light stays on that means no chlorine is being produced at this time. That is a big “uh-oh” for any pool owner. It also means your salt level fell below 2300 ppm. Yikes! Both lights will also stay on if the control is set to the wrong turbo cell type, or if the cell is unplugged.

Remedies: 

  1. Independently verify the salt levels in your swimming pool. You can utilize one of our at home testing kits, or you can get your water tested at your local pool store.
  2. Once your water has been tested, add salt to your pool to bring your levels back to the recommended 3200 ppm. You can review how to add salt on our site. If your independent testing shows your salt levels are correct, but your system is showing something different, you may need to recalibrate your Aqua Rite unit.
  3. Inspect and clean cell, if necessary.
  4. Verify if the control is set to the correct turbo cell.

 

III. Only ‘Inspect Cell’ Light Flashes

If the ‘Inspect Cell’ light flashes by itself, it is an early indication that the cell life is coming to an end. Each cell is equipped with 500 operational hours and requires a manual reset once it expires.

Remedies

  1. To reset the cell, hold down the ‘Diagnostic’ button for 3-5 seconds.

 

click here to find your replacement Salt System Parts

 

High Salt

The ‘High Salt’ light is exactly what it says There is literally a higher recommended amount of salt in your pool. Your unit will detect and alert this to the owner.

highsaltI. ‘High Salt’ Light Stays On

The ‘High Salt’ light will stay on for several reasons including: cell amperage is above the maximum limit, the control is set to the wrong turbo cell, or you simply have too much salt in your pool. The LCD display will read “HI”.

 

Remedies

  1. Independently verify the salt levels in your swimming pool. You can utilize one of our at home testing kits, or you can get your water tested at your local pool store.
  2. Once your water has been tested and the reading is too high, reduce the levels of salt in your pool to bring your levels back to the recommended 3200 ppm.
  3. Verify if the control is set to the correct turbo cell.
  4. Verify cell amperage to ensure it is not above the maximum limit for your model. Check below for the maximum current amps before the unit shuts down.

 

005

 

 

No Flow

The ‘No Flow’ light is an indication that there is something funny going on with the flow in your piping or the flow switch itself. If there is an issue with the flow, the ‘No Flow’ light will flash up to 60 seconds at start up. If none of the below remedies solves your issue, you may need to replace your flow switch.

Remedies

  1. If a LED is flashing, wait 60 seconds after starting the filter pump. Check for possible disruption inside of the flow T. yupInstallation requires 12 inches of straight pipe before the flow switch. There should be no elbow after the flow switch.
  2. If a LED is ON, check to see if the flow switch was installed correctly. The arrows at the top of the hex nut should point in the direction of the water flow. (Your flow switch requires a minimum flow rate of 11 GPMs  to stay consistently closed.
  3. Check the flow switch for damaged or cut wires.

 

 

Low/High Cell Temperature

Although there isn’t an error setting for temperature on the control, the LCD monitor will let you know if your water is either too hot or too cold for standard operation. The cell’s operating temperature range for the cell is 50F to 140F. The output is scaled back to 20% at 60F and output completely stops at 50F.

The LCD display will read COLD when the water temperature is below 50F.

The LCD display will read HOT when the water temperature is above 140F.

No manual is more efficient than the technical support provided by the manufacturer. The manual allows you to get familiar with your system and put your DIY skills to the test. If at any point you do not feel comfortable or simply just don’t know what to do, definitely give us a call. If it’s something that we can’t solve, we will put you in contact with a rep from Hayward.

Feel free to check out our how- to guide section for many more how-to guides dealing with the Hayward Aqua Rite system.

 

click here to find your replacement Salt System Parts

111 thoughts on “Hayward Aqua Rite Error Code Guide

  1. I am showing that I have no power to my T-cell. I have replaced the main board in the control panel twice with rebuild boards and had a pool guy out here to inspect (he was useless). I am currently running chlorine tabs in the skimmer as I did the end of last year just to not get anything growing as it is getting nice out. Is there a clear way to know if it is the cell or the control panel?
    Thanks

  2. I am showing that I have no power to my T-cell. I have replaced the main board in the control panel twice with rebuild boards and had a pool guy out here to inspect (he was useless). I am currently running chlorine tabs in the skimmer as I did the end of last year just to not get anything growing as it is getting nice out. Is there a clear way to know if it is the cell or the control panel?
    Thanks

    1. When you say there is no power to the cell, how are you testing that? Are you checking the diagnostic menu for the voltage and amperage? Or are you taking a voltmeter to the output?

  3. My Aqua Rite is displaying a code “HoE”. The “Generating Light” is flashing, while the Check Salt & Inspect lights are one. I can’t seem to find what this “HoE” code means. Appreciate any assistance. Thank you!

      1. How do I clear the code Hot I have a new cell and it’s set to the correct cell settings. I also put a new PCB in as well. What would cause this code? pool water temperature is 89f.

  4. I’m trying to recalibrate my system but it starts at 4000 and slowly drops to 3700 and just jumps out of calibration sequence. After 5 retries I got it to drop to 3600 and I set it . but multiple sets of the water tests shows salinity level of 2900-3000.
    how can get it to drop to 3000 before jumping out of the calibration sequence or start at a small number?

    1. If you are recalibrating but the system is still not working, I’d check that you have the correct cell type selected on the diagnostics page. Once that is verified, then I would check the cell voltage and cell amperage to determine if it is the cell or the main PCB.

    2. Move switch from off to on. After a few seconds, you will hear the generator kick in. Wait 5 seconds before pressing the diagnostic button 5 times, and do it slowly. This gives the system more time to stabilize to the instant salt reading, giving you more time to recalibrate it before the screen changes on you.

  5. I had some issues with this Aquarite system .. lead me to replacing both the display and the main board — now each morning it reads “700” on the display, as well as “CHECK SALT” and “INSPECT CELL” stays on (stated in earlier question that it blinks — but actually stays on) … go through the calibration routine and everything seems to go back to normal — until the next morning. (kind of like GROUNDHOG DAY) — what’s you thought?

    1. First, I would make sure it is wired correctly and that the unit is getting the correct voltage. If the circuitry checks out, I would do the following checks, I pulled from our article: Troubleshooting Your Hayward Aqua Rite System

      The NO FLOW LED stays ON when there is a flow switch problem.
      – Verify if your flow switch was installed correctly.
      – The arrow at the top of the hex nut points in the direction of the water flow.
      – Flow switches require a minimum flow fate of 11 gallons per minute to stay consistently closed
      – Check for damaged or cut wires

      Possible Remedies
      Step 1: With your pump running, double-check the positions of your valves.

      Step 2: Did you properly install your switch? The arrow should point in the same direction as the water flow. If it is not, re-align your flow switch.

      Step 3: Double check the wires on the flow switch for damage. If you see any damage, replace your flow switch. If there isn’t any apparent damage, keep reading.

      Step 4: Verify your pump’s pressure. If you see an increase in pump pressure, ensure that there is no blockage preventing the flow.

      Step 5: Replace your switch.

  6. I was getting a solid no flow indiciator light, so I have replaced the main Pcb board. The display doesn’t turn on when the power is on, but it turns on briefly whenever the power is switched off. I replaced the display and the same problem occurs. When I quickly switch the power on-off-on, the display finally turns on and the no flow indiciator is still illuminated. I’m $400 in the hole and it still without a solution.

  7. I have a older(2001) Aqua Rite chlorine generator with Tcell-15. I have repaired the thermister several times over the years and replaced the LCD display board a few years ago. A new cell a few years ago too. It has been running fine, until a recent problem.

    We were away and the pool water level dropped below the input line and skimmer. The pump and generator were on during this time, over a weeks time(on daily for 6 hours), with now flow to and from the pool. I have not refilled the pool as it appears there is a major leak and I will have a pool service check that. The pump runs with whatever water is in the filter. I am not sure if the pump impeller is damaged yet but I do not hear anything broken.

    However, when I turn on the pump/generator power, I expected only the “No Flow” lamp to be lit. But….the generator front panel has ALL lights on solid (not blinking), and the LCD display is blank.

    Did the condition of no pump flow for several day-cycles somehow destroy the Aqua Rite generator?

    1. This is a self-reply for others in the future…..

      Problem solved! I unplugged the cell cable, reconnected it, and the generator is now working properly. It must have had a bad connection. I shut the control valve to the skimmer/side inlet so it only draws from the bottom of the pool. The generator came on normally after the No Flow delay and is generating chlorine now.

  8. I have had an error code all summer but I can’t find out anywhere what it means. It says “HOE” but it’s not the whole E, it is missing the top horizontal lines of the E. It says no flow, and the generating button flashes. Does that make sense? We cleaned the cell. When i called the pool store she said everyone is having trouble this summer because it was so hot, and the temperature was up to 90 at one point, but now it is down below 80, and there is still the same error message. Thanks.

    1. The board is spelling “HOt” to denote the water temperature is reading above 140 degrees Fahrenheit. More than likely, this temperature reading is not correct. To determine if you need to replace the cell, check the water temp on your Aquarite’s control panel diagnostic’s. If the water temperature reads 215 degrees F, the cell temperature sensor is shorted and the cell needs to be replaced.

  9. We have a newer Hayward salt cell! Had to replace the stage flow sensor switch- now it reads the water temp at 208 degrees ? It’s 89. Salt cell didn’t produce chlorine- what’s up?

  10. System is not working. All four lights on panel are lit. No flow, check salt, high salt, inspect cell. Display reads. PCB. And at one point it showed 700. Do we need the display board or the control board.??

  11. I replaced the 5+ year old salt generating cell on the advice of my local pool supply store. Purchased and installed a new Hayward Goldline T-Cell 15 on my own two weeks ago – it’s no longer working. “Low salt” and “check cell” lights are on constantly even though a test of the water indicates that the salt level is within the normal range. It’s not genersting any chlorine at all.

    After looking at the end of the SCG cord that plugs into the main circuit board, I noticed that the side of one of the eight square plugs is brown, suggesting that there was a short [The brown one inserts into the socket on the top left corner of the receptacle on the board]

    The board is the OEM Hayward GLX-PCB-RIE replacement. It was installed only about a year and a half ago. It ran perfectly well with the previous SCG.

    I have no idea what to do at this point. Replace the board again AND buy another new cell?

  12. I have an Aqua Trol since 2011. It shows inspect cell and salt level illuminated steady. It always stays at 1600. I got the water tested and it was at 3200. I guess the cell is dead? Should I try to clean it again? After every summer it is cleaned with the special cell solution. Thank you.

  13. This spring I replace my control board. Turned the power on and the “check salt” & the Inspect Cell light are on, while the display panel is showing S lo. I checked my cell, it was clean but I decided to replace it since it was 6 years old. Installed the new cell (went from a t-9 to a t-15), changed the setting on my control panel. I added ten 40lbs bags of salt. Lights still on. I added five more 40lbs bags of salt. Same lights and error message are showing. Any idea what is going on?

    1. First thing, have you tested the salinity level to verify the actual salt level? That would be important as it would confirm there actually is a problem.

      Second, did you replace your original control board with an OEM or aftermarket part?

      1. I have not tested the salinity level yet. I replaced the control board with a after market part from your site (INYO said it was a comparable replacement for the original board).

  14. Led display says HOT all the time. Its new cell T-15 .Checked cell looks clean inside. Called tech support said the main PCB needs replacement . I am confused if its the sensor or the PCB. I don’t want to change both.Even the PCB is new bought bought in February 2018. from amazon ware house.

Leave a Reply

Your email address will not be published.

Recommended Resources

Water Chemistry For Saltwater Pools

– BLOG UPDATED 9/25/17 Some pool owners have a misconception that throwing shock into the pool and owning a salt chlorine...
Read Now

How To Add Salt To A Pool

October 29, 2020

Pool Care Basics How To Add Salt To A Pool In this Pool Care Basics, we show you how to add salt to a pool. Salt is only needed for pools that use a salt system to generate chlorine.

Watch Now

Why You Can’t Find Hayward or Pentair Products Online

If you’re wondering why you can’t find Hayward or Pentair products online anymore, wonder no more. The answer is simple: they...
Read Now

Looking for pool parts?

Shop Motors Shop Filters Shop Pumps Shop Salt Systems Shop Lights Shop Cleaners
Copyright © 2020 INYOpools All rights reserved