Pump not getting pressue

  • 23 Views
  • Last Post 3 weeks ago
PhillipB posted this 3 weeks ago

So i just replaced my motor that I purchased from you all and when I was cleaning everything out I noticed that my clear check value/viewing window has a couple of the screws stripped as well as one of the screws broken. I am no longer able to get full suction and pressure build-up. I know that I definitely need to replace this check valve/viewing window but I wanted to get your opinion on if you think I should replace my motor housing as well while I am doing this. I have included pictures of hopefully everything you need to see my 32k salt water sand filter set-up. Any advice is greatly appreciated!

Order By: Standard | Newest | Votes
InyoRob posted this 3 weeks ago

If you can't remove the fitting from the pump intake, you will need to replace the housing. It looks like some sort of epoxy was used around the fitting and intake port.

The way it is currently plumbed, you'd likely have to replace the check valve and 3-way valve as well.

PhillipB posted this 3 weeks ago

That makes sense. Can you point me to the correct part/part number for these two items? 

Is there any reason you would replace the pump housing at this point? I dont see any leak issues or anything but just wanted to be sure while I am replacing the other items. 

 

Thanks!

Phillip 

InyoRob posted this 3 weeks ago

If you can remove the fitting on the intake of the pump, you can salvage the existing pump housing.

Do you have 1.5" or 2" pvc plumbing? It is usually labeled on the pipe every foot or so.

 

PhillipB posted this 3 weeks ago

it is 1.5". 

InyoRob posted this 3 weeks ago

The check valve would be part number 25830-804-000. Click Here to View the 25830-804-000 Check Valve

The 3-way valve is part number 25933-151-000. Click Here to View the 3-Way Valve

Close