How To Replace an AutoPilot Salt Cell

WRITTEN BY:  Inyo Pools

  0 out of 5 stars on 0 ratings
(Click on a star to add your rating)

A salt chlorine generator cell will last about 3 -5 years before it has to be replaced. The following guide describes how to replace an AutoPilot Salt Cell.

Things You'll Need

Step by Step

Top

Step 1

The first step in replacing the Turbo Cell is to turn off the power to the pump and Chlorine Salt Generator. Ideally this should be done at the circuit breaker. The controller display should go blank.

Step 2

Open the air relief valve located on top of the pool filter. This will release the pressure from the system and make it easier to remove the cell.

Step 3

Unplug the cell cord from the AutoPilot salt cell.

Step 4

Unscrew the two unions on the salt cell. We recommend using a strap wrench or large channel locks if the unions cannot be removed by hand.

Step 5

Remove the Auto Pilot salt cell from the manifold.

Step 6

Place the new salt cell onto the manifold. The cell can be placed on the manifold in any position. There is no up or down direction for the cell.

Step 7

Tighten the two unions. This can be done by hand. The unions do not need to be overtightened with a wrench.

Step 8

Plug the cell cord back onto the AutoPilot salt cell.

Step 9

Turn power back on to the pool pump and salt chlorine generator. The controller should light up and the pool pump should operate.

Step 10

Any air in the piping should be coming out of the open relief valve. When water starts to spray out of the relief valve, shut the valve off.

Step 11

After a couple minutes the AutoPilot control box should display the output level, time, and temperature.

Comments

Top
(1 to 8 of 8)

Inyopools  Posted: 09/04/2017 11:16 AM  Inyo Product Specialist

Golfnmike - See Page 17 of Hayward's Aqua Rite Diagnostics Manual. If these steps do not solve your problem, give Hayward a call at 866-772-1200 and talk to their tech staff.


Golfnmike  Posted: 09/01/2017 20:01 PM 

I just replaced my Hayward Cell (T-15) but my Aqua Rite control panel is stating I need to check salt and inspect cell??


Inyopools  Posted: 06/04/2017 23:40 PM  Inyo Product Specialist

rwellesp - The new cell should show output in 1-2 minutes. Try spraying contact cleaner into the plug. Let it dry, then put the plug back onto the cell. Make sure it is on all the way.


rwellesp  Posted: 06/02/2017 18:21 PM 

how long before the new cell shows output. My auto pilot Nano system says warning: no output!


Inyopools  Posted: 08/06/2015 10:31 AM  Inyo Product Specialist

Gato - The power coming out of the Control Box has been converted from AC to DC. DC power can only be plugged into the cell one way. It cannot be reversed.


Gato  Posted: 08/05/2015 8:57 AM 

The cell cord connection to the manifold has two prongs (a third one is not use and plugged on the cord). Do I have to orient the plugs correctly as if each prong has a different voltage? It seems to work in either position.


Inyopools  Posted: 04/18/2015 10:44 AM  Inyo Product Specialist

power cord - No. You generally do not have to replace the power cord unless it is defective.


Anonymous  Posted: 04/16/2015 10:37 AM 

do you need to replace the power cord as well???