Power Supply, 115/36V AC Digital, 7HR, 2 PRF - 7184C

$270.99

IN STOCK
FREE SHIPPING

Part # 7184C

By Aqua Products


Details

Top

Part # 7184C

Product Description

AquaBot 7HR Power Supply 7184C

7 Hour Power Supply (115/36V AC Digital 2 PRF) for the following AquaBot Pool Cleaners:

  • AquaBot Turbo Classic
  • AquaBot Turbo T2


AquaBot 7184C

 

Please note that the old style plug is no longer available. The new power supply have a different style 2 prong female adapter. Plug, Aqua Products, Male, 2 Pin/2 Wire, For Flat Cable - A1615PK

Top

?     Asked on 4/5/2020 by

I have an old aquabot turbo classic. I'd say around 2002. The power supply is a 3 prong male receiver. Will this power supply work? There isn't a part number to look for.

 Reply

A  Answered on 4/9/2020 by InyoPools Product Specialist Patrick P.

Hi, Yes this 7184C AquaBot Classic Power Supply would be the proper replacement power supply for your AquaBot Classic shown in your photo. We do currently have this power supply in stock ready to ship!
 Reply


?     Asked on 7/10/2019 by anthony baglino

Hi. Is this a two prong transformer. Also, would you think this is the issue for the aquabot not running the complete 7 hours? or is it something within the bot itself. I did order and change the drive belts like I have done in the past so i'm not sure if it's the actual transformer, fuse, or aquabot internally. I am in the plumbing trade but the physics of this have me a bit confused...Please help and thank you!
 Reply

A  Answered on 7/16/2019 by Industry Professional

Once you set the Timer on the Power Supply it should stop after the time you set it for, it’s possible you have problems with the Timer.
 Reply


?     Asked on 5/23/2019 by Dwayne

I have a Aquabot T2 (Remote) and it has stopped working while in the pool. Everything appears normal at the power supply box (Model# 7088C-002) as far as the fuse, on/off switch and digital readout of 1-7 hours to run pool cleaner. I have checked the power source reading going to the power supply and getting 125 ACV on my voltmeter. When I checked the ACV that's exiting the power supply source, I'm reading 40 ACV. Is my failure in the T2 Aquabot with the capacitor? Thanks
 Reply

A  Answered on 5/25/2019 by InyoPools Product Specialist Patrick P.

Hi Dwayne, It sounds like you may have a bad motor in the head of the AquaBot Cleaner. I would suggest watching our Video on How to Troubleshoot Robotic Pool Cleaners the cleaner in the video is a Dolphin Robotic cleaner but the principles will be the same for your AquaBot.
 Reply


?     Asked on 7/21/2018 by D

auqabot supreme will not move when inserted in pool
 Reply

A  Answered on 7/22/2018 by InyoPools Product Specialist Lennox H.

Hi, D. To diagnose the issue, you will have to test the Power Supply and or the Cable. For other troubleshooting tips reference the Aquabot Supreme Operation and Troubleshooting Manual.
 Reply


?     Asked on 5/6/2017 by ray schrecker

can the timer be replaced in the power supply
 Reply

A  Answered on 5/6/2017 by InyoPools Product Specialist Lennox H.

Hi, Ray. Unfortunately, no internal parts other than the fuse is available for this power supply.
 Reply


?     Asked on 12/23/2016 by

is the power supply output AC or DC?
 Reply

A  Answered on 12/23/2016 by InyoPools Product Specialist Adam Y.

Good afternoon dfarris4@austin.rr.com, It is AC. If you have any further questions feel free to ask and have a wonderful Holiday.
 Reply


?     Asked on 8/30/2016 by Mark

My T2 transformer doesn't work. I want to make sure I'm purchasing the correct replacement. The barcoded label on the transformer is: 7098D0447201. Can you tell me the correct replacement part number?
 Reply

A  Answered on 8/30/2016 by InyoPools Product Specialist Stacey M.

Hello Mark, is this for a T2 Aquabot Turbo, just to verify please call Aqua Products 800-221-1750 to make sure your transformer lines up to your 7098D0447201.
 Reply


?     Asked on 8/27/2016 by Mark

All of a sudden the transformer will not turn on. I've tried a know good outlet and replaced the fuse but still no power. Any ideas?
 Reply

A  Answered on 8/27/2016 by InyoPools Product Specialist Stacey M.

Hello Mark, you might want to run diagnostic with Aqua Products 1-800-221-1750 so just in case there is anything needing to be reset.
 Reply


?     Asked on 6/6/2016 by bruce budde

I need a power supply for my aquabot turbo. serial number is gone but a number on the pump is 60-t a6001. It is quite old the motor is not original will 36volt supply run it ok?
 Reply

A  Answered on 6/7/2016 by InyoPools Product Specialist Patrick P.

Hi Bruce, Yes this would be the correct power supply for your Aquabot Turbo and 36V would be okay.
 Reply


Top
Difficulty

Est. Repair Time

Less than 1 hr

Tools Needed

None

Moved and lost it!

Written on 6/23/2020 by Guest

Had to buy another one as when we moved it magically disappeared 👻. I needed to get my pool cleaned up. Was super fast shipping. I paid the extra money for it to come overnight.

Were these instructions helpful? 
 

Top

Review Summary

 (Average 0  out of 5 stars)
0 Rating
5 star:
 
(0)
4 star:
 
(0)
3 star:
 
(0)
2 star:
 
(0)
1 star:
 
(0)