Leaking Pool Pump

Leaking Pool Pump

51 thoughts on “Leaking Pool Pump

  1. I’m afraid I’ve ruined my pool plumbing. I turned the engine off, but forgot to turn the handle from “filter” to “closed” before I opened the pump basket. Cloudy water filled. I replaced lid, and turned handle to “closed.” I waited a few minutes. Cloudy water (DEH leftovers) shot into my pool and turned it cloudy. (Least of worries right now). I turned handle to filter, cloudy (DEA residue maybe) water shot out. Heartbreaking part is that my plumbling that has been just replaced in leaking at every connection, even near the motor. Did I ruin it? Thanks for any input.

    1. I’m sorry but I do not understand the DEH and DEA acronyms. Can you explain them?

      Cloudy water usually is not a difficult issue to deal with and not normally a plumbing issue. Use a clarifier or floc and vac to clear it up.

  2. Hi Matthew,
    I have a slow leak under the pump basket and can’t see where it’s coming from. It’s not coming from the lid and doesn’t look like it’s coming from the drain plug. It started after I emptied the skimmer basket this week. Is there any test I can perform to see if the unit is cracked or where the leak might be?
    Another thing to note is that once the pump shuts off and it sits for several hours, there is air in the basket.

    1. I do not have much of a trick for this particular problem. The best this I would recommend is to let your pump pad dry, then start it up. Hopefully, you can trace where the leak is coming from easier on the dry pad. or you can remove the motor and basket from the housing to determine if you can inspect the inside of the pump housing for cracks.

    1. Is this on an above ground or inground pool suction line?

      Try the moke trick to find any hard to find air leaks. Use incense or cigarette smoke to find any sucking air leaks. Wave the smoke around the pipes in question, the smoke should be pulled into the offending leak.

  3. Hi there,
    Just installed an “new to me” pump in my system. However, when I turn on the pump, water begins to comes up from the fitting that has my discharge pipe (flex pvc) which goes to my sand filter. I’ve tried retreading with teflon tape, I’ve tried loosening it, tightening it (should I be tightening only hand tight?).

    Any ideas on how I can fix this? The leak is quite bad.

      1. Hi, I am experiencing a leak at this discharge point also. I have done the same, tightened, moved the tighteners to different spots and used plumbers tape. However, I am noticing it may be coming from the black pipe seaming this hose slides onto instead. This is a brand new Hayward pump from last summer. I am not familiar with parts names etc, my husband normally set up the pool stuff. Unfortunately, he passed last Fall. I am trying to give my high school senior one more year of summer fun. I am hoping you can recommend something for me to try so this leaks stops. It is not a bad leak, but it does leak. Thank you and hope to hear from you soon!

  4. You seem to be quite responsive which is great, so I’ll give it a shot – I have a jandy pump with a leak between the inlet coupler and the pump. The O-ring is in tact, but when I unscrewed the coupler I noticed the pump and the PVC pipe weren’t exactly flush. Does the coupler when tightened make them flush, in which case I probably have a cracked thread, or is there something bigger that would require repositioning the pump?

    If it’s a cracked thread, is there a way to fix that without replacing the coupler entirely?

    1. If the pump wasn’t leaking, then all of a sudden it is, and in the interim, you haven’t fiddled with the union any, I would say it could be a crack. But instead of hypotheticals from me, I would take a look at the actual port.

      Regarding a fix, you can use stuff like JB Weld to mend a crack. But if it is severe, you may need to bite the bullet and get a new housing.

  5. I’m troubleshooting the pressure in the pool filter getting too high. I have a drip water leak coming out of the tension control clamp of my FNSP60 pool filter. I just replaced the complete element grid assembly and am still having high pressure. Do you think replacing the tank clamp o-ring would fix the leak? What are your suggestions?

  6. I had a leak at the discharge side of my pump. Replaced the pipe (leak was at the coupling that comes directly out of pump top). Cleaned filter, lubed o ring at valve attached to the pipe, replaced drain basket and o ring (lubed it as well). When I started the pump back up, after filling it with water, there was no pressure going to the filter. You can feel water moving through the pipes and no leaks seen with soapy water or smoke.
    Checked slimmer basket and all jets and can’t find any issue. Any other suggestions???

    1. Does your filter have an air relief valve? This valve will release any trapped air in your system which can restrict flow. The air relief should be used after each time you open the pump, filter or chlorinator.

      1. The filter is a Hayward Starclear Plus, the valve has limited air flow. You can feel a trickle of air from it, but no spray of water like when typically open and pressurized. I recently replaced the pressure gauge just to make sure that wasn’t the problem

  7. I have a leak between at the impeller joint on Hayward pump, where it;’s held together with a big (15″ maybe) tension collar band. Is this just a bad O ring? Something else?
    Thanks

  8. I have high pressure around 30 psi when water flow directed to spa that spills over into pool. When only directed into pool psi drops to 10. We also have 2 jets in the spa that seem to have little to no flow. We ran the hose and water does flow. We replaced our DE filter and now we noticed a new leak around the pool pump. We replaced the o rings and now water shooting from housing. Did the high pressure crack the pump or is the pump causing the whole pressure problem? Pump is an max-e-pro installed in 2015.

  9. Matthew-
    Thanks for the reply
    The label says
    “Pump Model Number
    PE 5E- ????? ( illegible)
    Made in USA A87F”

    My guess is it’s 25+ years old.

  10. Matthew,
    I just replaced my shaft seal on my Hayward SP1510 pump and noticed the housing gasket is kinda bad shape. I know I need to replace it but is ok to run my pump for a day until I can get a new one?

    1. Yes it is ok to let your pump limp through a day or two if you are there to keep an eye on it; but you’ll want to repair it asap. If you have to be away from the pump, then it is best to not let it run. Those housing seals can go quickly, and when they do, the water just gushes out.

  11. We just got a new Under ground pool. The soil is wet at the equipment going back towards the pool. The pool company has tested the pressure of the equipment and says it’s good. Asked if they’re now going to test all the lines to see if there is a leak and I am told there is no need since the pool equipment has pressure . Who was leaking somewhere the equipment would not have pressure . Based on reading all of your other answers to people I call BS . If your equipment holds the right pressure then your pool is not leaking somewhere else ?

  12. I have water spraying out of the top of my hayward pump (pressure side) between the fitting and the housing. I also have a gurgling water noise in the top of my hayward sand filter. It seems like there is so much pressure built up that it is is wanting to leak at this location. I wrapped the threaded fitting 4-6 times with teflon tape but still spraying water out of it. Any ideas?

    I should also state I had sand coming into my pool so I changed my lateral assembly and put new sand back in 300 Lbs. I still have a little sand coming in its been two days running.

    1. It does not sound like the Teflon tape is the issue. have you checked for a crack on the discharge port of the pump? Is there an o-ring that is warped or missing from that union joint? You may have air in your system from the leak in your pump. If the pump loses prime after it shuts off, it is likely in part due to the pressure side leak. If you fix the leak, you may fix the air issue.

  13. I have just replaced the lateral assembly and put in new sand, is it normal to have some residual sand for a few days after ?

    1. If the filter was backwashed and rinsed like you should after adding new sand was added, then there shouldn’t be any sand flowing into the pool. If the filter was not backwashed then you may have some sand blowback, but the issue should last a few minutes, not a few days.

  14. I have a intex salt water pump just got in a month ago and there is water leaking between the skimmer and pump when the pump isn’t running. It just started doing this about a week ago. Any idea what could be the issue?

      1. The part between the skimmer and the pump would usually be a section of hose. If it is only leaking when the pump is off, then there may be a pinhole leak. When the pump is running, the leak may be drawing in air instead of leaking water. But when the suction of the pump is shut off, gravity takes over, so water begins to leak.

  15. Hello,
    We have a DE Filter and a Hayward pump. When we first turn the pump on, the pressure gauge reads 10 psi, which is the normal operation pressure. But after some time passes, the PSI increases to 20. Sometimes this happens within minutes, and sometimes it takes an hour or so. We do notice that the concrete under the pump itself is sometimes wet, like there is a leak in the pump somewhere. Could a leak at the pump cause the pressure to slowly increase like it does?

  16. Hi Inyo Pools,
    It seems that this seems to be a common question and I am sorry if I am repeating something that has been answered before. We have a Hayward Super II SPX 3000 in a home we just purchased and it leaked. From the paperwork I found, this was installed 1995. We read on your site about doing the kit to replace seals and gaskets. We purchased the SPXHKIT2. We also replaced worn parts on the motor and filter housing parts. After all was said and done, the pump leaks still between the pump housing and the seal plate. Before we did the kit, it leaked at the top of the pump housing and seal plate, and after the kit it now has minor leak at the center side bolt on one side. (if that makes sense, sorry) Maybe every 30 seconds about 4 to 5 drops. On one of your instruction pages it stated that the housing gasket should be a tight fit.
    Step 16
    Insert the new housing gasket in its groove. These new gaskets are tight. You may have to have someone hold half of the gasket in the groove while you are inserting the other half. Put a thin coat of lubrication on the gasket. Use a good pool parts lubrication.
    This was not the case with the housing gasket that we had with our kit. It fit loosely in the groove for the gasket. We used the lubricant provided and put assembly back together. We now have this little leak left. Is the housing gasket not right? Any help would be appreciated. Thank you.

    1. Thank you for the question. I would take apart the pump just to make sure the gasket wasn’t pinched or some other mishap found a way to mess with the seal during installation. if the housing gasket looks to be ok, I would look for any warping or cracks in the seal plate or housing that is allowing the water through. If the parts check out, I would reinstall everything carefully then start up the pump. If could be a faulty gasket or just a loose nut; but with either of those, you need to take it apart again.

      1. Thank you for the prompt reply! We really appreciate your input. Obviously you have had to deal with this issue over and over. We will try the gasket and make sure that there are no cracks. We will give you an update to our progress. Thanks again!

    1. I guess you could open the strainer lid, then pour in some water to see if there are any leaks in the housing. But you won’t know for sure that the pump is watertight until the pump is running and has water pressure.

  17. I just replaced the shaft seal, and have checked the housing for cracks with nothing noticeable. However I still notice my pad is wet under the pump. I can’t figure out what else would be leaking. Any suggestions?

  18. Matthew, I just received new motor and a go kit for my pump. When I replaced the shaft seal on the impeller side, it did not fit snuggly on. Now matter how hard I pushed and turned, the seal would not seat properly. After putting the pump back together, after pressure builds, water spills out into the motor. I obviously turned it off right away! What is the problem?? Help! It has to be the shaft seal. It did not even look like the one I took off. I sent a picture of my pump to you and this was the kit I got. Guy said it is a Hayward superpump. Andrea

    1. It sounds like you still have a piece of the old shaft seal on the stem of the impeller. When you removed the old shaft seal, did the impeller stem look like the picture below? If so, the shiny metal at the base needs to be removed for the new shaft seal to be properly set.

      shaft seal on impeller stem

      1. I put 3 in 1 oil on the impeller shaft before Installing my new shaft seal. It worked for a week and I started to see a leak between housing and plate. Did I compromise the new shaft seal? I didn’t replace the housing or diffuser gaskets yet.

        1. I answered your question on chat or some support ticket, but I will restate it here for any future readers. Do not grease, lube, or oil your impeller or shaft seal. Any additives will corrupt the seal causing the leak you have now. The shaft seal is so sensitive, even fingerprints (and the oil left behind) can cause the seal to fail quicker than expected.

  19. I have a Hayward Super pump and we have been having a leaking problem, i replaced the shaft seal and the ceramic seal as well as some of the other o rings. When i put the pump back together it ran great with no leaks for about 24 hours then we noticed that when the pump kicked back on the following day there was a noticeable leak coming from the bottom of the pressure side. We ended up doing a full replacement of our pump motor and i hooked it up today and the same problem happened again. So now i have a brand new pool pump motor but am still having a small leak coming from the bottom of the pump and or engine.

    1. When they replaced the motor did they change the seals of the pump housing? The motor is not responsible for holding in water, that is the duty of the gaskets and o-rings. The most likely culprit is the housing o-ring or the shaft seal.

  20. Hi, I have an old hayward super II pump, probably original when the house was built ~20 years ago. It is leaking and I can’t find the source. water seems to come from underneath the pump and then accumulates below the pump and motor. I just had to replace the variable speed motor because the electronics and motor housing corroded, most likely due to pool water. When installing the new motor I checked that the new gasket was properly inserted and that the copper inserts where the housing bolts go in are firmly attached. I also cleaned the mating surfaces before attaching the motor to the pump housing. After all this the pump still leaks from underneath
    Any suggestions to find and seal the leak?
    There is also a smaller leak on the discharge side of the housing where the pipe joins. Any ideas about re-caulking or other ways to fix this?
    Many thanks in advance

  21. Ihad/ have a Pentair intelliflo 011028, just replaced the 011018. The old one started to leak, so we changed the seals and gaskets, but, because it had been leaking for a while, apparently, a lot of the pump had corroded, by the screw holes, so it wouldn’t sit snug on the plate. We had a storm, which blew the keypad assembly ( only 18 months old, and expensive!) so decided to just buy a whole new pump! Well it is leaking right off the bat! Installed by pool professionals! And leaking in the same spot my old pump leaked! They have changed seals, took apart put back together, now talking about replacing the seal plate. Any ideas?

Leave a Reply

Your email address will not be published.

Recommended Resources

Why is my skimmer lid blowing off

PSC Ep. 75: Why is my skimmer lid blowing off?

In today’s episode of Poolside Chat, Rob and Matt tackle another common swimming pool question:  When the pool pump shuts off...
Read Now
Bubbles coming out of my pool return line

Why Do I Keep Getting Bubbles In My Jets?

Everybody loves a bubble bath, show me a person who doesn’t and I’ll show you a liar. Bubbles are fun but...
Read Now

Does my pool have a leak, or is it just evaporation?

December 13, 2018
Does my pool have a leak, or is it just evaporation? Today we’re going to be talking leak detection, and joining...
Watch Now
should i put vaselien on my rubber gaskets?

Poolside Chat Episode #24: Can I Use Vaseline On My O-Rings?

This is Poolside Chat where every week we answer your questions on how to fix and maintain your swimming pool. Poolside...
Read Now

Looking for pool parts?

Copyright © 2020 INYOpools All rights reserved