why-is-my-pump-not-working

8 Answers to “Why Is My Pool Pump Not Working?”

As pool technicians, we hear these everyday:

“My pump is on but the water is not moving.”

“Why is there water leaking from under my pump?

“Why is my pump losing its prime?”

And the classic but vague, “My pump isn’t working, what’s wrong with it?”All these and many others are signs of a failing pool pump but the source of the fault varies. The key to diagnosing the pump is understanding its parts’ functions and what happens when a certain part is failing. Knowing what to look for allows you as a homeowner to identify and fix the problem yourself, thereby saving money. Or if you’re not up for the job, be able to explain the issue to a pool technician so they can fix your pump. Most importantly, being educated on your pump prevents you from being pushed into buying unnecessary parts by your poolman.

We’ll do a rundown of the 8 most replaced parts on a pool pump with an explanation of each part’s function and the symptoms of a possible issue.

Inyo Recommends PureLine Prime Pumps

1.) Motor

Symptoms

  • Grinding or Screeching – A sign of bad bearings caused from age or rusting. Bad bearings are also a sign of a leaky shaft seal.
  • Loud Hum – If the shaft is spinning then it is likely the capacitor failing. If the shaft is not spinning then the bearings have frozen and locked up the shaft.
  • Flipping Breaker- A deep internal component within the motor has failed and requires the motor to be replaced or rebuilt.
  • Silence – The shaft of the motor has frozen providing you with a new 30 pound paperweight. There is no chance of rebuilding the motor, the only route is to replace.

A pump’s motor is the heart of your pool. Put simply, if it’s not a pumping then you’ll be a slumpin’. Generally, motors have a lifespan of 3 – 5 years. The life of a motor can vary greatly upon the conditions it endures in its application. A motor exposed to the summer sun, spring rain and early fall freeze will likely burn out quicker than a sheltered one . If you’re concerned about weather effects, we suggest using the Universal Motor Cover to protect your investment.

The Fix: How To Replace the Motor on Your Pool Pump, How To Wire A Pool Pump,

2.) Seal Plate

Symptoms

  • Obvious wear and tear, i.e. cracks

The seal plate is the joining point of the motor and the pump housing. Damage to the seal plate is usually caused by an over tightening of either the motor or housing bolts. Excess tightening will cause cracks in the frame and eventually form leaks.

The Fix: Replace Seal Plate

3.) Gaskets & Seals

When someone says they are seeing wet cement on their pump pad, the usual cause is a bad gasket, shaft seal or o-ring. These rubber parts seal the joints of your pump making it watertight. Each seal failure will affect your pump in a distinct way. If your pump requires multiple gaskets replaced, we suggest applying a Gasket and O-ring Kit (GOKIT) if available. We also have a guide on installing a gasket kit:  How To Use a Tune up / GO-KIT

Shaft Seal

Symptoms

  • Water dripping from motor vents
  • Loud bearings
  • Rusty motor casing
  • White whirling on motor face

Arguably the most vital and sensitive of the bunch, this $12 – 20 part is last line of defense protecting your $200 electric motor. And I shouldn’t have to tell you but water and electric motors do not get along very well. The seal consists of two sides: a white ceramic ring sleeved in a rubber protector and a spring loaded side with a carbon ring. If your shaft seal begins to fail, water will leak into the motor casing. This small leak will begin the process of corroding bearings, copper windings or electrical components. Friendly reminder, whenever replacing a motor always replace this seal.

The Fix: How To Replace a Pool Motor Shaft Seal

Housing Gasket

Symptoms

  • Wet pump pad
  • A leak coming from the seal plate and housing seam

The largest of the gaskets acts as the seal between the seal plate and pump housing. Diagnosing a faulty housing gasket is easy due to its location. If water is spilling from the large seam between the pump seal plate, then this would be your culprit.

The Fix: How To Replace Pool Pump Gaskets

Lid Gasket

Symptoms

  • Large air bubbles in strainer basket
  • Low water pressure
  • Takes longer to prime pump

“Why am I getting air in my system?” The answer to that question always begins with checking the lid o-ring of the pump. Unlike the other gaskets on the list, a bad lid gasket causes a sucking leak rather than a blowout. The usual sign of a bad lid o-ring are larger than normal bubbles in the strainer compartment. The air leak may also cause a hissing sound.

The Fix: How To Replace Pool Pump Gaskets

Diffuser Gasket

Symptoms

  • Losing prime
  • Low water pressure

This important but sometimes forgotten part, the diffuser and its gasket enhance the pulling power of the motor and impeller, enabling the pump to prime itself. Located at the tip of the diffuser, the gasket seals the diffuser/impeller assembly to the front part of the housing. The funnel-like diffuser is then able to focus the impeller’s pulling energy, increasing its strength. This aids in priming and maintaining water pressure.

The Fix: How To Replace Pool Pump Gaskets

4.) Impeller

Symptoms

  • Losing prime
  • Low water pressure

The motor may do all the spinning, but the impeller does all the work. Found screwed onto the end of the motor shaft, the impeller is a vented or veined disk. These veins act as a boat propeller would, drawing in and then pushing out the water. If your impeller is broken then you will see little to no flow of water. There may be a rattling as well caused by broken pieces of impeller within the housing.

The Fix: How To Replace A Pool Pump Impeller

5.) Diffuser

Symptoms

  • Low pressure
  • Loss of prime

The diffuser is a cone-like shroud that sits over the impeller. Its main function is to focus the impeller’s pulling force towards the pool to enhance the water draw. A broken or cracked diffuser will have cracks that siphon off the impeller’s pull, lowering water pressure.

The Fix: How To Replace A Pool Pump Diffuser

6.) Strainer Lid

Symptoms

  • Large air bubbles
  • Obvious or hairline cracks
  • Warping

The strainer lid is the main visual inspection point of your pump. Or in simpler terms, it’s where you check to see your pump is running. Lids become brittle with age and can break or warp from excessive sunlight.  Hairline cracks in a cover can create a sucking air leak allowing air to slow your system.

The Fix: Replace Strainer Lid

7.) Strainer Basket

Symptoms

  • Rattling noise within strainer basket
  • Clogged impeller
  • Torn or damaged cartridges

The strainer basket catches debris before it reaches the guts of the pump. A broken basket can harm your pump or filter because it misses debris that can damage the impeller, diffuser or filter cartridges.

The Fix: Replace Strainer Basket

8.) Housing

Symptoms

  • Dry rot
  • Cracks forming near ports or bolt holes
  • Obvious wear and tear

Considered the hull of the pump, a housing encases all of the above parts. A pump housing failure is usually seen coming because of obvious long-term degradation of the pump. The sun is usually the biggest culprit when it comes to housing damage. The pump getting baked during the summer months will cause the housing to start petrifying and becoming brittle. Cracks will begin to show around the stress points. The housing is the second most expensive part on a pump to replace, only behind the motor. If the housing and a few other parts need replacing, it may be best to replace the whole pump. Read our previous blog on determining what to do in this case: Pump or Motor: To replace or not to replace… That is the question.

145 thoughts on “8 Answers to “Why Is My Pool Pump Not Working?”

    1. My pump is flowing backwards. The end that water should be coming out from is actually sucking the watter through that end.

  1. Thanks Matthew for the advice on what might be wrong and what kind of pool pump repairs I need to remedy the situation. Hopefully the motor isn’t shot on my pump! I will call my pool contractor as soon as I can.

  2. Pump runs great. is when I connect the hose and barracuda that looses suction and doesn’t clean. what do you think it is?

    1. Check the hose sections fo air leaks; there may be a few pinhole sized cracks that are killing your suction power. Cover the ends, then submerge each hose length, if you see air bubbles then you got a sucking air leak.

  3. I’m trying to drain my pool down using the maon dtain, but the pump doesn’t work now that the water level is down about half way. Skimmer is closed off. I replaced seal and gaskets. Tried prming. Still won’t pump. What am I doing wrong?

    1. Joe, how are you closing the lines to the skimmer? Are you closing it with a diverter valve or plugs? Have you checked for air leaks in the lin i.e., elbows, valves or tees? Does your skimmer have an equaliser line that is not closed?

  4. Hi!! We are losing prime on our pump after about 2 hours. I believe there’s a pinhole in our filter housing and a crack at the top of the filter housing. It is slowly leaking. Would this be the cause of the loss of prime in the pump?

      1. Hey bud my pool got to low now my pump isn’t pumping the water into pool. Do I need yo reprime the pump? If so how do I do that

  5. Pump primes well but seems to lose suction after about 10 minutes. I replaced the impaler and gaskets about a month ago. Please help

  6. Pump keeps loosing prime. The water in the skimmer rises and falls in correlation to the pump flux. I’ve clean skimmer and pump baskets. Checked the seals and impeller. I’ve noticed hairline cracks in the impeller but no missing pieces. I see no signs of leakage or loss of water. The water is clear.

    Any further ideas?

  7. Pump leaking at housing interface. The pump/impeller don’t seat all the way into the housing any more. I didn’t make any changes and cannot get it to seat all the way in which is causing it to leak at that point. The large screw ring is tight as I can make it.

    1. What is the model number of your pump? It could be a warped seal plate or a bad lock-ring.

      Have you checked that the housing oring is not pinched between the housing and the seal plate?

  8. My motor is leaking/dripping from a plug . Is this an easy fix or should I call someone? Pump has been off now ten hours 🙁 . When i shut off motor water shot out and lid popped off . How to to fix:( new to this pool thing just moved in haven’t even used the pool yet.

    1. So, is water leaking from the pump’s drain plug? Motors do not have plugs, at least not that I know of.

      What is the model number of your pump? I have not seen a pump lid pop off, after it was turned off.

  9. I replaced my 1 hp pool pump motor over the weekend. I installed exactly the way it came out, but the motor will not come on. I had an electrician friend test for power at the leads on the motor and it is receiving power. I took it back to Pinch-a-penny and the motor tested fine. They went ahead and gave me another motor, but the new one isn’t working either. I’m totally lost on why it isn’t working. Any suggestions? Thanks in advance.

    1. Do you have the motor set to the correct voltage? If the motor you received is a dual voltage it comes set to 230 volts it will not work if you are running 115; you will need to set the voltage using the knob or jumper switch at the back end of the motor.

      1. I have the same problem. I received a Pentair Optiflo 1.5 HP 2 speed above ground pool pump that is an exact replacement for my old pump. It’s rated for 115v. Plugged it into the outlet and nothing happened. I checked that power is getting to the outlet and even tried plugging the pump into an outlet unrelated to the pool and still nothing. Any recommendations? Thank you.

  10. My husband tried to clean the basket filter near the pump while the pump was still on. The water that gushed out of the filter went into the pump. Now the pump will not turn on. Is there a solution to this or was the the end of our pump?

  11. Following a recent evening power outage, the pump fails to run. The display reads as if it were running, I flipped all the breakers and still nothing. Any advice or guidance is greatly appreciated…

      1. I am trying to find out how to make sure my pump is connected properly because Walmart sold me a pool with the wrong pump gave me the right one but no instructions

  12. I have a Hayward pump from quite a few years back.
    I did a smoke test and saw the smoke is sucked into the pump area.
    Is this sign that there is an air leak and my pressure will not go up further (always sitting at no more than 7psi), and therefore would not prime.
    What do I look for next?

      1. It is definitely beyond the strainer housing. Somewhere around the seal plate and motor mounting plate area. Do I need more test to pinpoint the location?

        From what I read, do I need to change the gasket by removing the motor? or something else?
        Is it a complicated procedure requiring special tools?

        Also is a normal pump supoposed to be quiet during its normal operation?

        Thanks
        Oliver

  13. I have an in-ground liner pool. I recently upgraded both the pump and filter to larger horse power and capacity respectively. The psi usually shoots up to 20 and the Kreepy will not work. I noticed that when I take the filter element out, the psi drops to 10 and the Kreepy works just fine. The filter is new – any suggestions???

      1. My pump is humming and doesn’t flow water what could it be changed the rod in the impeller it was broke now it still isn’t working can it be cause by not enough water in pool I’m lost

  14. Hi There was a car accident yesterday which caused a power outage for about an hour. since then my pool pump hasn’t worked.

      1. I have a similar issue where, after flipping the tripped breakers, the display shows the filter operating but the pump is not running. When I reset the breakers, I hear a “pop” coming from the pump but nothing happens. Any ideas? Thank you.

  15. 0/09/17 Happy New Year! I ran the pump overnight for cold weather (at 38degrees when started) in Apopka, Florida. It worked fine overnight on previous day. When I checked to see if it was still generating chlorine the digital readout stated “no flow” but motor sounded normal.
    I took off the clear cover over pump basket area and it was full & steaming hot and filter also dry so no water went through. Pool return was bubbling (maybe blowing air)? Impeller, diffuser or cap issue? Please heeeelp!

    1. Hayward super pump is controlled by intermatic model 154-00456. I can hear the timer gears moving and checked with multimeter that both timer and pump have power. But there’s no noise at all from the pump when I turn the manual knob on the intermatic. Removed the motor assembly from the wet housing unit and was able to spin the shaft by turning the impeller with my hand. Also checked the capacitor with multimeter. It seems to be charging and discharging. At a loss

      1. Does the motor fire up when the timer activates it for its normal schedule (i.e. not using the manual switch?) Was the motor creating any odd sounds before this switch issue started?

        I suspect there is a part deeper within the motor that has failed. You will likely need it tested by a motor shop. But you can get some free advice from our friends over at TroubleFree Pool Forum

  16. Thanks for your great help! My variable speed pool pump was working just fine & now the lcd unit used to program said pump will not stay on, meaning that it flashes on/off every 10 seconds and the pump won’t work. I have checked circuit breakers, etc but no luck. Please help…I’m going insane!

    1. First, I would check if your motor is still under warranty. If so, contact the manufacturer immediately to initiate a claim. If not, you may need to replace the variable drive controller. Some motor manufacturers do not offer a replaceable drive or if they do, it could be the price of a whole new pump.

  17. I have an above ground pool. When installed the pump was not screwed to anything so it’s just sitting in plastic. When I started pump up it was leaking badly where the two pieces of pump go together where the screw area is on outside of Hayward pump. I have this problem a lot. I think it could be not screwed tightly enough at connection. But the plastic part in skimmer part is connected. Any thoughts?

  18. Hi…my girlfriend’s pump isn’t working. When she plugs it in…it hums but motor does not spin. Help?!

  19. I purchased a brand new Hayward 1.5 pump for inground pool. It worked at first but once it ran for about 15 minutes it stopped and once it cooled down it started again. I notice it keeps flipping the breaker. Do I have to install a new breaker and wires? It’s also hooked into a timer that doesn’t work anymore so I just shut the timer off and use the switch. But still the same thing keeps happening. What do you suggest?

    1. First I would try moving the pump to a different breaker to make sure it is still operational. If the motor still works fine on the different breaker, then I would switch out the breaker. Also, test the original breaker and circuit wires to confirm they are still viable.

      1. My handle turns correctly, but just won’t backwash. All others work. Rinse, recirculate, waste, filter. Just the backwash does not pump out water.

  20. I am new to pools and I got a new filter and pump put in. It was working fine until the rain started coming down. now it seems like the pump isn’t working correctly? Could it be too much water in the pool? Please help.

    1. Can you be more specific when you say “it seems like it is isn’t working correctly.” What exactly is the pump doing?

      Also, too much water in a pool is not going to affect the pump. But too little water will.

  21. I cleaned the filter on my pool. The pump turned on and I left. I can back 5 hours later and 5he pump is off and not turning on.

    1. We will need more information than that to troubleshoot the motor. Has the breaker flipped? Was the pump running dry? If this was a sand or DE filter, did you release the air from the system?

      If you did not, the air bubbles in the plumbing can prevent the pump from priming, allowing it to run dry, and overheating the motor.

  22. I have the same issue with the pump on my sand filter. It was on running fine when I left the house yesterday, but was not running when I returned, even though the switch was “on”. I checked the electrical box and the breakers hadn’t tripped. Does this mean the motor on the pump died? I already have a back up pump on hand in case I need to replace.

      1. Could you please tell me why my pool sand pump will only work for 2 hours and then it will have to be back washed again and again and will only work for two hours consistently? Thanks.

  23. My pump won’t turn on. It is a Polygroup that is only one yr old?! Any ideas what is going on with this? I also have a friend who has a polygroup pump, again 1 yr old and won’t turn on. It isn’t the main plug…I am stumpped and frustrated with the kids wanting to swim in this hot weather 😥

  24. My pump seems to be running fine , has a good pressure and blows out just fine but doesn’t seem to be filtering and the suction isn’t quite as strong but does blow out the return with plenty of force. I leave mine running all the time to keep the metal from my well water filtered out. Well it would not clear and stayed a very light green for the last three weeks like it wasn’t filtering correctly, so last night I turned off the pump for the night and it’s is a dark brown today like maybe something trapped in the filter came back into the pool as I had not added any water or clorine, it just seemed to not be filtering out correctly because when I backwash it was not pulling the metal color water from the filter. It doesn’t seem to have any air leaks but the suction it’s as strong as usual. I changed the sand in the filter this year as I do about every 2 to 3 years because of my heavy metal problems. Terri

  25. My “less than a year old” variable speed pump is making a grinding nopise like it has striped gears. just started this and won’t prime at all. the noise is really loud. i am leaving it off.

    1. Ok, well have you opened the pump to check if there is anything stuck in the impeller? Can you tell if the pump is leaking? i.e. the pump pad is wet though there is no rain?

      The sound could be a bad bearing, which is covered under most warranties (as long as it was not caused by an installation error.) Contact the dealer from where you bought the motor, to find out the warranty procedure.

  26. I was vacuuming my pool yesterday and the pump was running fine. For some strange reason, last night I noticed that the pump wasn’t sucking in water from the pool with full power. Is it possible I clogged something? I cleaned out the filter after I vacuumed too. I even cleaned out all the strainers. Could the pump just be overworked? I just bought this one in May brand new.

    1. This may as simple as an air leak, or a clog. The air leak is the quickest thing to check; use incense stick smoke to find the source of an air leak. Light the stick, then run it along the suction-side pipe and pump; is there is a leak then the smoke will be pulled in.

      Clogs are a little bit harder, get a pipe snake to try fishing out any pipe debris.

  27. I was emptying my green pool using my pump on waste mode. It emptied 95% of the pool water and then although the pump is working but it is not pumping out any waster water out of the pool. What could be the reasons and how can I fix it?

    1. Because the water level is significantly lower, the pump now has to pull the water from a deeper point. If you have a smaller pump, the added feet of vertical rise is too much for it to stay primed. Buy a sump pump.

    1. It could be a lot of things, we would need more info on it. Did it trip the breaker? Have you tried turning it back on? If so, what happened (or didn’t happen)?Was the motor making any noises before it suddenly stopped? If so, what were said noises?

  28. I have a small above
    Ground pool the pump was working fine but then it started kicking off after a minute of running. I have tried everything that I know from changing plug ins to cleaning everything and still can’t seem to get it to run for 1-2 minutes then it shuts off. What else am I missing or is the pump burned up…when it runs it does good.

  29. my filter gasket lid keeps making a sucking effect when the filter is turned on. when it is off the water begins to leak from the top of the lid. I made sure to seal the lid with magic lube from a pool store, however, this is still occurring.

      1. Do you mean it is making a sucking sound? if so, is it s sucking sound for water or air? Does your system lose prime?

        Intex is not always known for their quality, so I wouldn’t totally discard a faulty gasket as the cause. If you can get one for cheap or free for from the dealer you bought it from, I would give it a try.

  30. Matthew,
    My la01n booster quit working. The shaft at the back spins freely, I took the impeller/front off and it spins and is free moving. I replaced the capacitor on top. When electricity is applied, the shaft spins., the motor hums for about 5 seconds and then the whole thing shuts off. What do you think is wrong? Thanks.

    1. You may have two: a run capacitor and a start capacitor. Some motor have a governor at the electrical end of the shaft. Check that it is not stuck open. If your capacitor(s) and governor are good and the motor shaft rotates easily you probably have a burned out motor coil and you will need to repair or replace the motor.

  31. What would cause a pump to lose some, but not all, of it’s suction over a 12 hour period? Here’s my setup: I have a 1 hp Flotec motor/pump driving a Hayward Navigator Pro pool cleaner, attached via the skimmer. I know the suction level is a tad low for the Hayward, but it has worked just fine for several weeks, scooting all around the bottom of the pool without issue. I usually run the pump for 8 hours a day, but I just ran it 3 days straight while adjusting chemicals and clearing cloudy water after a big storm (Irma). However, this morning the Hayward is no longer moving about the pool. The pump is still running, water is still flowing out of the returns, but the suction level is noticeably lower. That explains why the Hayward isn’t moving. There are no water leaks near the motor/pump, there are no inlet air leaks, the pump skimmer basket is clean, the cartridge filter was cleaned out yesterday, and the pressure gauge on top of the filter looks good too. The noise of the motor/pump is the same as it’s always been. Is it possible for a pump to slowly lose suction?

    1. Here are a few guides you might want to use to troubleshoot the problem. You should also check the cleaner hose line for any pin hole leaks. These tiny leaks slowly pull in air causing the gradual loss of suction you are describing. Seal each hose length with tape or something else and submerge the hose in the pool. If there are air bubbles coming from anywhere other than the ends, then you have a problem.

      How To Determine Why a Pool Pump Won’t Prime
      How To Prime a Pool Pump

  32. I have a question. My Mom’s pool pump is only 1.5 years old but the other day it made a loud bang like a firecracker, then it just stopped for good. The local pool company sold her a new capacitor as that is the most common cause of a pump not starting, however, I can’t imagine a capacitor making a giant bang when it stops working, so either they simply don’t listen to their customers or they sell them things they don’t need. They kept her original working capacitor. Pinch-a-Penny sucks. Anyways, when we turn it on there is zero sound at all. My guess is the entire motor is blown.

    I suppose electrical issues could make a loud bang, but she didn’t see any smoke afterwards so I’m thinking dead motor. Any suggestions?

  33. I have an Intelliflo VS Pump model 3050, 3.0 HP and I’m running it with an electric generator because we just went thru hurricane Maria and the screen is reading ” Alarm Over Voltage”.
    Do you think the motor is damage? I’m trying to reset it and it’s not working. My son bought it thru EBay and sent it to me. Help

  34. My pump seems to be losing its prime after 4-5 days runs on a timer works fine then gets air bound.there is no air in pump once running and system is very quiet.flushed out line from pump to strainer it’s clear ,checked seal on pump cover all tight also checked gasket in union all good.any taughts

    1. In that interval of 4-5 days, is your water dropping below proper levels? It could be natural evaporation or a water leak in this case. Another cause of low water is a leak from a multiport valve waste port.

  35. I have a salt water pool with a spa where the pump is located. When the pump came on it used to rise about 6″ above the surface of the water. Now it just about makes to the surface. All I see is the water pouring up. I keep the filter clean but that doesn’t help. I been seeing some black dirt spots on the bottom of my pool lately which I vacuum out. I don’t know where the dirt is coming from. Could this have something to do with my problem? Could the dirt be getting into the system and interfering with the pump coming up the way it use to?

  36. My pump works for about a minute than it’s still running and I loose all pressure. Than it like reprime itself for about a minute. At this time everything is working good and than it looses all pressure again. And this just steady repeats itself. When it looses pressure the pump seems to sound the same.

    1. There may be a sucking air leak on the suction side of your plumbing (the pipe before the pump.) The areas of concern pump lid o-ring, diverter valves, joint seams and vacuum hoses.

      Everything except the vacuum hose can be checked using the smoke trick. Wave a lit cigarette or incense stick along the length of the suction side pipe. If there is a leak the smoke will be drawn in.

      For the vacuum hose, take a section of hose, seal each end with tape, then submerge in water. If you see air bubbles from the body of the hose, replace that length of hose.

      Read this article for more information: How To Determine Why a Pool Pump Won’t Prime

  37. I have this Pentair intellipro variable speed pump, and it stopped working this morning. There is power but no water flow. It’s been cold here in Florida the past nights and I covered the pipes yesterday with towels. What should I do? Thanks!!

  38. My pool pump sometimes does not come on, does not trip breaker. I have to pound the pump casing and then trip breaker. The capacitor has been replac, what else could be the problem?

    1. So, does the breaker trip after you give the pump a jolt?

      Since you have already changed the capacitor, you should check is the motor shaft is frozen/locked up. To do this, you must remove the motor from the pump, and unscrew the impeller from the shaft end. With the impeller removed, try spinning the motor by hand. If the shaft does not move or takes a lot of strength to do so, then the motor should probably be replaced. You can try to replace the bearings (Part 1, Part 2), but may not fix the issue.

      And of course, before you do any of this motor removal, shut off the breaker to the pump.

  39. The not starting is now and then, sometimes when we trip the breaker we hear a hum on the motor, give the motor a hard wack, it starts. Seems like something gets hung in the motor and when you wack it it must knock it loose.

    1. Do you know if your motor has just one capacitor? Or does it have two? Also, if the latter, did you change both?

      If there is a hum, most of the times it is a bad capacitor. If you hear a screaching or grinding noise while the motor is running it would be a bad bearing.

  40. After getting a local company to put in a new liner, our pump seemed to be having issues with pressure. In order to run the polaris, you have to close off one of the inlets (from the pump back to the pool) so that you have enough water pressure to run the polaris.

    Now the pump does not prime or move water. I cleaned the impeller to no avail. If I add a portable pump to the system and direct it’s output to the skimmer intake to the pump, I get enough water flow to run the system. But it’s still not enough to adequately filter the system.

    1. Have you checked for air leaks in the suction lines leading to the pump? That would explain why the pump can’t prime/pull the water to itself; while the portable pump that is pushing the water does work.

    1. This could be an overheating issue. Most common causes of overheating are low voltage or excessive strain, like too large of an impeller or old bearings adding drag to the draft. The latter can usually be heard because bad bearings make a loud screeching noise.

      You’ll need a multimeter or to call an electrician to check the voltage. For the bearings, you must remove the moor form the pump, and unscrew the impeller. Then with your hand (no tools,) try to spin the motor shaft. If the shaft does not freely spin, then your bearings may be rusting.

  41. My pool was working just fine, then a HUGE thunderstorm came thru. It dropped hail and lots of
    water.. Now my pump is off and i’ve tried flipping ALL the breakers in the house to see if it resets but it’s still not working. All the pool pumps and equipment are under a covered patio. What can it be?

  42. Pureline brand new 1.5hp above ground pool pump along with it’s now replacement 3/4hp pump will flow water but loses prime when vacuum hose attached. All gaskets checked. Even held all the vacuum hose under water in case of a hole. Still won’t vacuum.

    1. It could be that the Pureline pump is not producing enough flow to prime with the additional length of hose. Have you tried reducing the length of hose to see if that corrects the issue?

      1. pool is 18 x 33 cannot just clean half of it. It appears the air is coming in from the lid gasket. I will have to see if a different rubber gasket will make a tight seal. Had no issues for years until I switched to the pureline with its new wet end design.

  43. I have a brand new Vflex pool vac, everything has been replaced inside the vac. I replaced the pool pump, and the filter. My question is why does my vac clean half of the pool and Stop mid way of cleaning? Doesn’t matter where it starts from it still stops. There is no debris in the pool everything is clean. Why do I have this issue?

  44. We just tried to turn out pump on and it will not come on. We’ve checked the breakers & everything. Any ideas?

  45. hello, we were cleaning the pool, and when it was time to clean the pump out, we hooked everything back up. turned the pump on it came on,worked fine, then the pump shut off, did the reset and test came on, then the pump shut off, had to wait a few mi . did the reset, came on, until we got done vacuuming, cleaned the pump out again, after shutting pump off. then we tried to turn the pump back on after we got things back in and on, did the reset again, this time the pump did not come back on, we checked the fans,they work freely, the rod to the motor moves freely, we did the reset again, all we get is like a thumping noise, wants to start, but not working. could this be the compacitor?

  46. Matthew,

    First time pool owner and it has been a crash course. I mistakenly removed all of the DE and ran the pump for several months. Was getting a flow error but couldnt figure out why (i now know it was due to no DE). The motor has stopped working (no humming). Would running the pimp with no DE cause this? If I add DE, do you think the motor will restart?

  47. I am not getting any power to my pool pump. I have replaced mini breaker and still have no power. Can you help?

  48. I just bought a Summer Waves quick set up. The pump is an RX600. Its leaking tons of water from the top and bottom over called polygroup several times. They aren’t very helpful and the instructions stink. Any advice?

  49. My AO Smith pump displays “overcurrent fault” and advises to rotate the shaft. I did that and the shaft turns OK. When I turn the power on it hums for a second, then stops and then displays the “overcurrent fault” message again. I suspect it’s related to a power outage we had a few days ago. Could the power have surged when it came back, and damaged the capacitor maybe? Thanks for all the help you’ve given here, it looks like this page keeps you busy!

  50. i just replaced a motor. impeller wasnt turning very well when i installed brand new motor. not sure why. after wiring in, got humming noise but impeller would not spin. why? i put new shaft seal also

    1. Do you have the motor set to the correct voltage? If you have a dual voltage motor (very common) they come set from the factory to 230 volts. If you are running 115 volts, you will need to manually switch the motor over. If the motor truly is new and you have eliminated any circuitry concerns then you may have a defective motor. Contact the vendor from whom you purchased the motor to get it replaced.

      1. Hi just wondering if I have a simple issue or a more complicated one. I’m switching my pump to 115v from 230v to get enough power to my pool equipment to run a heat pump. The pump runs but pressure seems lower than before (1-2psi, used to be up at 7psi). Is there a switch out of phase on the pump, or is there another issue? The motor is definitely switchable.

  51. My pool filter pump sounds like the propeller wants to go but then doesn’t and makes a quick click noise…reset button and test button dont make a difference. Have tried multiple outlets all working for other things except pool pump…I took pool filter apart and nothing is broken or rotted. Why is it not working?? Please help.

  52. I just went out to turn on my pool pump. It sounded as though it was going to prine and operate as it normally does, but suddenly just stopped. No sound just nothing. Now it wont come on at all. The only thing different is we had been having some electrical issues in our house with lights getting brighter when appliances come on and APS came attached a ground or neutral wire from our house to our neighbors because ours is not working. Would that cause a problem with our pool pomp?

  53. Hello i have a intex sand and saltwater filter. Set it up and i have power but its not making any sounds.. theres a red 7 or 1 on the main screen.. when i press any of the buttons i does nothing.. o chrcked the impeller and its free..

Leave a Reply to Gary Cancel reply

Your email address will not be published.